A-A+

详细讲解:通过composer安装TP5.1(Thinkphp5.1)

2020年03月30日 后端 评论 2 条 阅读 533 次
守财鹿邀请码

现在TP5越来越火了,TP5也更新到了5.1版本,但是5.1以上版本只能通过composer来进行安装,那么这里贴出详细的步骤

前提:PHP版本必须要5.6以上, 这个可以先在本地安装一个phpstudy,新建一个站点设置php版本 大于5.6就行。

在Phpstudy服务器中打开对应php版本的php.ini文件,找到extension=php_openssl.dll前面的分号去掉,意思是打开ssl扩展,目的是为了能在cmd命令中能进行访问。

 

安装composer.phar

(1)打开composer中文网http://www.phpcomposer.com/

(2)点击上图导航的“下载”,找到下载内容的地方,去下载当前最新版本的composer.phar

(3)下载到你想下载的文件夹中,例如我下载在wwwroot\tp51.com文件夹下面,下载后我们可以在文件夹中看到composer.phar

(4)   下载之后我们并不需要安装,得到这个文件就可以了,直接就可以用,测试composer.phar的可用性,那么我们就需要从cmd中通过命令进行检测啦
    测试可用性我们分成几个步骤来:

1)首先找到phpstudy中PHP版本的php.exe文件的位置

比如:D:\phpstudy_pro\Extensions\php\php7.0.9nts\php.exe

2)打开命令窗口:win+R然后输入cmd按回车得到命令窗口

找到我们装composer.phar的位置

3)拼接好之后,我们就可以测试composer.phar的可用性啦,语句:我们phpstudy中所用php版本号的php.exe所在路径+一个空格+composer.phar+空格-V(最后一个V必须是大写字母V))

-V指令是查找composer的版本

到此我们的composer就安装好了,接下来就可以进行下一步了

 

安装TP5.1

复制下面的语句

create-project topthink/think=5.1.* tp5

粘贴到cmd命令中:php.exe路径+composer.phar+刚刚复制的语句

我的这里完整的语句是这样的:

D:\phpstudy_pro\Extensions\php\php7.0.9nts\php.exe composer.phar create-project topthink/think=5.1.* tp5

前面一段 是php.exe的位置,你的位置可能跟我的不一样,然后后面的tp5 这个也可以修改,这个是框架安装的文件夹名字,可以自己取。

上面基本就安装完成了,你现在就可以到你的站点目录去部署你的站点了。

 

 

打赏
微信扫一扫支付 微信扫一扫支付
微信logo微信扫一扫        微信logo支付宝扫一扫
你的鼓励是我前进的动力!

2 条留言  访客:2 条  博主:0 条

  1. 今日新鲜事

    文章不错支持一下吧

  2. 今日新鲜事

    文章不错非常喜欢,支持一下吧

给我留言

Copyright © WEB小工匠 保留所有权利.   渝ICP备15008469号

渝公网安备 50023602000173号

用户登录

分享到: